This project is read-only.

Support for Windows 8 RTM

Topics: Windows 8 JavaScript, Windows 8 Xaml
Aug 10, 2012 at 9:22 PM
Edited Aug 10, 2012 at 9:23 PM

The Preview 5 version of the Player Framework Extension SDK (.vsix) will work on both the Release Preview and RTM builds of Windows 8 and Visual Studio.

For those using the source and samples zip with the Windows 8 RTM, please make the following manual changes to the projects:

1) For both the JS and Xaml sample app, you will get the build error: “Error 1 Windows Runtime type 'Windows.Foundation.Point' was found in multiple referenced winmd files. Please remove either 'C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0\ExtensionSDKs\Microsoft.VCLibs\11.0\References\CommonConfiguration\neutral\platform.winmd' or 'C:\Program Files (x86)\Windows Kits\8.0\References\CommonConfiguration\Neutral\Windows.winmd' from the list of referenced files.”

To fix, go to the AdaptiveStreaming WinRT project and remove the reference to the Microsoft Visual C++ Runtime Package. A warning will replace the error but can be ignored.

2) For the JS sample app only, you will have a build error: “Could not find SDK “Microsoft.WinJS.1.0.RC, Version=1.0”.

To fix, go to the main Samples project, remove the Microsoft.WinJS.1.0.RC project reference and re-add the latest WinJS reference (Windows Library for JavaScript 1.0).

3) For the JS sample app only, you will need to update the WinJS script tags.

To fix, Open default.html and replace all 3 references to “Microsoft.WinJS.1.0.RC” with “Microsoft.WinJS.1.0” (remove the ‘.RC’).

An updated version of the source and samples zip specifically for the RTM will be available soon.

Aug 12, 2012 at 8:41 PM
Edited Aug 12, 2012 at 8:42 PM


Since upgrading to RTM build of Win8 and VS, my application no longer plays videos.

I tried isolating the issue with a simple C# application using;

<Grid Background="{StaticResource ApplicationPageBackgroundThemeBrush}">     

 <mmppf:MediaPlayer Source=""/>   


And indeed nothing happens, that is when the app launches, the screen stays black with no video playing and no control bar either.

Would you have any suggestions?


Aug 16, 2012 at 8:34 AM

Bump - I have the same issue. Playing a video (even basic progressive) just shows a blank screen, no controls. Nothing in fiddler either. 

Windows 8 RTM, VS2012RTM, SmoothStreaming Client beta 2 and player framework preview 5.




Aug 16, 2012 at 11:40 PM

Actually after re-installing Win8RTM from scratch, I was able to play videos.

Aug 16, 2012 at 11:46 PM

Note about original post: today we released a Preview 5 Refresh build that drops support for Win8 RP and targets RTM exclusively. The steps I posted earlier are only needed when using the older Preview 5 release and are no longer needed for those using the newer Preview 5 Refresh.

Thanks, Tim

Aug 16, 2012 at 11:51 PM

@jakkaj, I'm not sure what is happening here but it sounds like this is fixed by repaving Windows according to @scrainic. I'm just guessing, but as an alternative you could try making sure all the player framework files are removed by:

1) Uninstalling the Player Framework SDK from VS (Tools | Extensions and Updates).

2) Manually deleting all PlayerFramework folders from C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0\ExtensionSDKs

3) Reinstalling the .vsix (be sure to get the new Preview 5 refresh).

Hope this helps,


Aug 21, 2012 at 10:03 AM


I'm having the same problems as jajjak and scrainic. Before RTM the video's were playing perfect but now I'm just getting a blank page.
I've installed the smooth streaming sdk beta 2 and the player framework preview 5 refresh.


Uninstalling and cleaning the local folders doesn't help at all.

Any help would be much appreciated.



Aug 21, 2012 at 3:30 PM

I am running Windows 8 RTM and attempted to play the bigbuck.mp4 from the Getting Started guide. I get a video window with a play button, when the play button is clicked nothing happens except the video box flashes and displays the play button again.

I noticed that people have had the previous version of Preview 5 and are upgrading to the refresh version. I have only ever installed the refresh version and still no luck.

Aug 22, 2012 at 4:54 AM
Edited Aug 22, 2012 at 4:58 AM

I set up RTM on a new PC, and the videos worked for a while - but then they stopped working again - its bizarre (on the preview 5 refresh)

Aug 22, 2012 at 6:27 PM

@jakkaj, @EmoGeek, & @Bitzie007: can you please try the samples app (included in the source zip)? We're unable to repro so this would help identify whether its specific to your your app or not. Also, are you using the Xaml or JS version? Lastly: smooth or progressive. Thanks!

Aug 22, 2012 at 7:17 PM

I have attempted several of the sample js apps in both chrome and IE without success. My app uses Xaml and I've tried both smooth and progressive.

I have also created a blank metrostyle app and followed the getting started instructions from:, unfortunately I'm met with the same results.

Aug 23, 2012 at 9:34 PM

Today I completely formatted my PC. Installed Windows 8 RTM from scratch and installed Visual Studio 2012 Pro Trial (not RC). Whatever the problem was it has now magically been fixed. I am still using 5 (refresh). The only change from my previous setup is that I now have VS 2012 trial installed instead of RC.

Aug 24, 2012 at 12:47 PM

I've tried running the samples but they also didn't work. I'm using XAML atm.

Like EmoGeek I've made a blank app and still nothing works. But I've just seen that I can't run any video on my Windows installation. 
Even after reinstalling Windows  I'm not able to play any video in any app. Could it be a problem with the video-card?

Me and 2 other colleagues have the same problem with Windows 8 and we all have an ATI video-card in our laptop.

Aug 26, 2012 at 2:54 PM
Edited Aug 26, 2012 at 3:37 PM

I'm having problems too, since I updated to Win 8 RTM. Live streaming was working perfectly in Win 8 RP, but now the player crashes. This is the error:


   at System.TimeSpan.Add(TimeSpan ts)
   at Microsoft.PlayerFramework.MediaPlayer.OnNaturalDurationChanged(Duration newValue)
   at Microsoft.PlayerFramework.MediaPlayer.<.cctor>b__d7(MediaPlayer t, Duration o, Duration n)
   at Microsoft.PlayerFramework.MediaPlayer.<>c__DisplayClass3d`1.<RegisterDependencyProperty>b__3c(MediaPlayer t, T o, T n)
   at Microsoft.PlayerFramework.MediaPlayer.<>c__DisplayClass34`2.<RegisterDependencyProperty>b__33(DependencyObject d, DependencyPropertyChangedEventArgs e)
   at Windows.UI.Xaml.DependencyObject.SetValue(DependencyProperty dp, Object value)
   at Microsoft.PlayerFramework.MediaPlayer.OnMediaOpened()
   at Microsoft.PlayerFramework.MediaPlayer.<OnMediaOpened>d__29.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<ThrowAsync>b__0(Object state)
   at System.Threading.WinRTSynchronizationContext.Invoker.InvokeCore()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()

This happens only when I navigate the second time to the view.xaml that contains the player. I believe it has something to do with resetting the player.Source url. The first time I navigate to the view I work almost always fine.

Any ideias?


Aug 28, 2012 at 4:33 AM


Okay - I have good and bad news. The good is that it's not the media framework doing it - no videos play, even in a media element. (which is also the bad news I guess). 

Even apps from the store do not play - they load etc, just don't play video. (Tried the TED talks one). 

So... I reformatted, once again RTM everything. Still no video.

My system is a MBP retina. My desktop is a PC and it runs stuff fine...

I tried different resolutions etc (in-case 2880 was causing issues), to no avail.

Aug 28, 2012 at 4:58 AM

Another update - have tried it on a non retina boot camp MBP, (MID 2010) and it also will not play videos... must be driver related.

Aug 28, 2012 at 11:46 AM

@ricardoschiller, i had the same problem, i think there is an error there.... meanwhile gets fixed, i've downloaded the source code changed Mediaplayer.cs to this:

        void OnNaturalDurationChanged(Duration newValue)
            if (newValue.HasTimeSpan && newValue >= TimeSpan.Zero)
                //EndTime = StartTime.Add(newValue.TimeSpan); // this will trigger Duration to get set

PS: I only play smooth streaming videos so i don't care about endtime right now... :)

Aug 28, 2012 at 5:01 PM

Hi villagra, thanks for the reply.

Meanwhile i've done just about the same thing. But this error was easy to catch. My current issue is that sometimes videos just don't play. And worse even, there is no error and the behavior seems random to me. Sometimes they play, sometimes they do not...

Sep 5, 2012 at 1:00 PM

I am also facing the same issue on RTM have anybody got the solution?

Video is working perfectly, player crashes only when i play Live streams.

Also the app does not crashes on the first run. It always crash on the second attempt.