Missing refered dlls

Topics: Windows 8 Xaml
Sep 25, 2012 at 1:02 PM

Hi All,

I created a Win8 store style app project and gave reference to Player Framework, Player Framework Adaptive Streaming Plugin and Microsoft Smooth Streaming Client SDK. It works fine on my local machine, but when I run it Remote debug mode or Install Package to an other Win8 machine, it seems refered dlls are missing. I’ve got this exception:

System.IO.FileNotFoundException

   at System.StubHelpers.StubHelpers.GetWinRTFactoryObject(IntPtr pCPCMD)

   at Microsoft.Media.AdaptiveStreaming.AdaptiveSourceManager.GetDefault()

   at Microsoft.AdaptiveStreaming.AdaptiveStreamingManager.Initialize(MediaExtensionManager mediaExtensionManager)

   at Microsoft.PlayerFramework.Adaptive.AdaptivePlugin.Microsoft.PlayerFramework.IPlugin.Load()

   at Microsoft.PlayerFramework.MediaPlayer.InitializePlugins()

   at Microsoft.PlayerFramework.MediaPlayer.OnApplyTemplate()

 

Have you got any idea, how to solve this problem?

 

Thank you in advance!

Tamas

Coordinator
Sep 26, 2012 at 1:58 AM

Hello Tamas, when using PlayReady and/or Smooth SDKs you need to also add a reference to the VC++ runtime or the app will not run on machines without VS installed.

Sep 26, 2012 at 10:52 AM

Hi Timgreenfield,

 

My refered assemblies are:

.Net for Windows Store Apps

Microsoft Media Platform: Player Framework

Microsoft Media Platform: Player Framework Adaptive Streaming Plugin

Microsoft PLayReady Client SDK

Microsoft smooth Streaming Client SDM Beta 2 for Windows 8

Microsoft Visual C++ Runtime Package

Windows

 

If I comment out the adaptive streaming plugin from my XAML code the app works fine, but the player not play adaptive streaming. Other case I get the error what I mentiond previously.

 

Regards, Tamas

Coordinator
Sep 28, 2012 at 8:46 PM

Can you please make sure you're doing a 'release' build instead of 'debug'? We had one other developer encounter this but only with debug; release worked fine.

Thanks, Tim

Oct 1, 2012 at 1:42 PM

Release deployment did solve the problem for me

Oct 4, 2012 at 9:27 AM

Yes, Release did solved my problem. Thank you!

Oct 12, 2012 at 8:29 AM

We also had this problem. Deploying in Release mode solved it for us as well.

Nov 6, 2012 at 2:43 PM

This has worked for me as well, but is there no use case for remote debugging on devices which can't have the SDKs installed (e.g. MS Surface on ARM)? Until now my workflow has had me deploying onto a remote device for debugging, which I can no longer do if I wish to use the adaptive streaming plugin.