This project is read-only.

Video always fails to play on ARM

Topics: Windows 8 Xaml
Nov 1, 2012 at 9:40 PM

Trying to use the player in my app, and it works perfectly in the simulator, but when I try and do the same thing when running my app on my Surface, it just fails with "MF_MEDIA_ENGINE_ERR_SRC_NOT_SUPPORTED : HRESULT - 0xC00D36B4" every time.

Everything is being built for ARM (when deploying to Surface), so not sure what I've missed. Any help on this would be appreciated.

Nov 2, 2012 at 11:31 PM

Hello, this should work. Are you playing smooth or progressive media? Also, do you happen to have a test media url I could use to repro the issue (or does it happen in the sample for you)?

Thanks, Tim

Nov 2, 2012 at 11:38 PM

I'll give it a try with the samples and see what happens. The url itself points to a local service (it's intended to be done through a local network). I could give you a sample URL, but you'd have to let me know when you would be able to look at it as it will be running on my PC which might not be turned on. I'll try with the samples first though.

Nov 2, 2012 at 11:46 PM

Have also just noticed that in between me first putting it in my app to when I got round to writing the original post there's been a newer version, will try with that too.

Nov 3, 2012 at 12:10 AM

Right, tried the latest version and it still fails to play, have tried putting one of our urls into the Progressive streaming example in the sample app, that fails to play it too.

Happy to take this offline to discuss and give you a URL (although not today, 11pm here in the UK). If you want to drop me a PM with an email address I can send some details to.

Nov 4, 2012 at 1:35 AM

I just ran some tests with our samples app using remote debugging on the Surface RT in release mode targeting ARM and everything is functioning as expected. Therefore, I suspect it has something to do with your url. When you say you are using a local service and a local network, does this mean you are not using http[s]? I'd like to understand more about the source of your media.

Other things you can do to confirm your app & debug config is correct is to just try the sample as is ...and... to try your app with a url from our sample. If both work, this will further confirm the problem is specific to your media (or the way you are serving it).


Nov 20, 2012 at 8:02 PM

I have the same problem when I play mp4 trailers from youtube. in my app, I tend to get mp4 url and while the player goes full screen, non of the controls are visible and no video. audio plays alright. if you need sample url, let me know

Nov 20, 2012 at 8:06 PM

correction.. after killing the app and trying again, it seems to play alright.. this is just weird.

Nov 21, 2012 at 10:50 AM

does it work also for Playready protected Smooth video(on ARM)?