PlayReady has started to fail for some reason

Topics: Windows 8 Xaml
Nov 9, 2012 at 1:40 PM

I'm trying to run the PlayReady sample (http://code.msdn.microsoft.com/windowsapps/Simple-PlayReady-sample-5c1aefaf) on my machine but am continuously seeing the Playback Failed screen.

This was working perfectly fine for me a couple of days ago, and I can't figure out what might have changed to cause the error. Is there something I can do to identify what's going on with the certificates?

I'm getting the following logging output:

Enter Playback.Play()
Creating protection system mappings...
Creating media extension manager...
Leave Playback.Play()
CurrentState:Opening
Enter Playback.ProtectionManager_ComponentLoadFailed()
Windows.Media.Protection.RevocationAndRenewalInformation
\Windows\System32\dlumd64.dll
Reasons=0xUserModeComponentLoad, EncryptionFailure
Renewal Id=00000000-0000-0000-0000-000000000000
\Windows\System32\Drivers\dlkmd.sys
Reasons=0xUserModeComponentLoad, InvalidComponentCertificateRoot
Renewal Id=00000000-0000-0000-0000-000000000000
Leave Playback.ProtectionManager_ComponentLoadFailed()
MediaFailed Source: http://playready.directtaps.net/win/media/TallShip_with_Credits_folk_rock_soundtrack_encrypted.wmv
*****************************************Playback Failed************************************
MediaFailed: MF_MEDIA_ENGINE_ERR_SRC_NOT_SUPPORTED : HRESULT - 0x80070241

Nov 13, 2012 at 3:46 AM

Most likely you have upgraded your graphics driver to one that has not been signed for DRM protected playback.

[)amien

Nov 13, 2012 at 5:30 PM

Thanks, yeah this turned out to be the problem.