Can not play smooth streaming in Windows Phone 8

Topics: Windows Phone 8
Jan 9, 2013 at 9:13 AM
Edited Jan 9, 2013 at 9:14 AM

I wrote exactly what

http://playerframework.codeplex.com/wikipage?title=Getting%20Started%3a%20WP8%20Smooth%20Streaming%20Player&referringTitle=Windows%20Phone%208%20Player%20Documentation

told me in a windows phone 8 app, except added a AutoPlay="True" in player's attribute list. However, it can not play neither the URL that the documentation provided nor other smooth streaming URL. The output window in VS2012 said there is a "System.Xml.XmlException" type exception in"System.Xml.ni.dll", and the app just crash without any warning.

 

    <Grid x:Name="LayoutRoot" Background="Transparent">
        <mmppf:MediaPlayer Source="http://mediadl.microsoft.com/mediadl/iisnet/smoothmedia/Experience/BigBuckBunny_720p.ism/Manifest" AutoPlay="True">
            <mmppf:MediaPlayer.Plugins>
                <adaptive:AdaptivePlugin />
            </mmppf:MediaPlayer.Plugins>
        </mmppf:MediaPlayer>
    </Grid>

 

Someone please help me.

Jan 9, 2013 at 7:13 PM

samething. I am not able to play a content in my WP8. It throws null reference exception on AdaptiveStreamingManager. Any body encountered this issue?

Jan 9, 2013 at 7:29 PM

sen3,

You may want to try using the solution I had to employ to get the Progessive Download plugin to work way back in the 2.5 / 2.6 release of SMF Player (Microsoft Media Platform was originally named Silverlight Media Framework).  The problem in a nutshell is that the namespaces were renamed in 2.5 / 2.6 and exceeded the max allowed namespace for 7.1 Mango.  It's possible that your plugin is also buried in a lengthy namespace and causing the same issue.

See: http://smf.codeplex.com/discussions/280487

 

-Paul

Jan 11, 2013 at 5:56 AM

No one knows?

Jan 15, 2013 at 5:10 PM
Edited Jan 15, 2013 at 5:11 PM

Thank you paul. It worked in HTC windows 8 phone. I doubt the version of the windows phone os is the issue. 

Coordinator
Jan 15, 2013 at 9:15 PM

Hi folks, I'm trying to repro this but have been unable to.

One thing to double check is that you have added a reference to the smooth streaming dll: C:\Program Files (x86)\Microsoft SDKs\IIS Smooth Streaming Client\v2.0\Windows Phone\Microsoft.Web.Media.SmoothStreaming.dll

...without it, the app will crash and close without much additional info.

Also, here's my test project; if you have a chance, please give it a try to see if it has the same issue.

Lastly, if you're still experiencing issues, please let me know if it appears to be specific to a certain device or specific emulator.

Jan 18, 2013 at 11:46 AM

It works! And I really don't know why, our projects are exactly the same, but still, thank you very very much!