MEDIA_ERR_SRC_NOT_SUPPORTED error on Surface Pro

Topics: Windows 8 JavaScript
Mar 20, 2013 at 11:24 PM
Edited Mar 20, 2013 at 11:27 PM
I've been working on a Win8 Store app using the Player Framework and has so far been working fine, however live streaming is failing on a Surface Pro with the exception: "MEDIA_ERR_SRC_NOT_SUPPORTED (0xC00D0035)", and displays "The video failed to play. Try again".

I have built and run locally on a Windows 8 desktop, and remotely on a Surface RT and both work fine. However, no matter what I do it always fails on the Surface Pro. I set up the event listener to catch the error and that is what I get.

I'm using Expression Encoder Pro talking to a Windows 2008 R2 server running IIS live streaming services on an internal server. I've disabled the firewall on the Surface Pro, and no change. If I open the http manifest URL in a browser it pulls up the XML content just fine, so it's not a connectivity issue. Also, there's no entry in the IIS log for an attempt to connect, success or fail.

I've tried using the IP address and also hostname in the http URL, and same result. Again, both of these work in the Pro's browser and also on all of the other computers and platforms. I only have this one Surface Pro to test against, so I can't say with certainty if it's specific to just that.

I should also mention that the test URL that was included in the code sample (http://stream8.france24hd.yacast.net/f24/f24enwp7.isml/manifest) DOES work on the Surface Pro. I don't have any other links to test, but again, my Surface RT and the two Win8 desktops I used play it fine on the same wireless network without any trouble.

I'm pretty stumped here. What else can I do to try to track this down?
Mar 21, 2013 at 12:17 AM
Okay, so I was able to make it work by mapping the server to an outside IP address and using an outside public Wi-Fi network to access it. I have verified that under Project -> Properties -> Debugging I have "Allow Local Network Loopback" set to "Yes".

So somehow it is blocking LAN access from just the app? Since I can pull up the manifest URL fine in a browser on the tablet.

Is there another setting somewhere else that controls the ability to access local LAN from the app?

Odd that it works fine on my RT but not on my Pro. The Pro is domain-joined, but even with firewall disabled, it still doesn't work on local LAN.

How does PlayTo overcome this?

It would be great if I could continue to test the app on the local server so I don't have to jump to external Wi-Fi each time. Any suggestions?

Thanks!
Coordinator
Mar 22, 2013 at 8:28 PM
I'm don't know if this is the issue or not, but please check your package.appxmanifest capabilities to ensure "Private Networks (Client & Server)" is checked.

Hope that does the trick.
Mar 22, 2013 at 8:38 PM
Brilliant! That was exactly it -- thank you so much!