This project is read-only.

Windows 8.1 - Visual Studio 2013 update 4 - manifestready - Unhandled Microsoft .NET Framework exception

Topics: Windows 8 JavaScript
Nov 14, 2014 at 11:21 PM
I'm currently using the following code to subscribe to the "manifestready" event in a SmoothStreaming PlayReady solution using Windows 8.1 and the latest version of Player Framework:
        var propertySet = new Windows.Foundation.Collections.PropertySet();
        var mgr = mediaPlayer.adaptivePlugin.manager;
        mgr.addEventListener("manifestready", onmgrManifestReadyHandler, false);
        propertySet["{A5CE1DE8-1D00-427B-ACEF-FB9A3C93DE2D}"] = mgr;
All is perfectly working using VS2013 update 3.

When I update my environment with the latest Visual Studio 2013 update 4, I receive the following exception when propertySet["{A5CE1DE8-1D00-427B-ACEF-FB9A3C93DE2D}"] = mgr; is executed:

An unhandled Microsoft .NET framework exception occurred in WWAHost.exe [7832].

The player is crashing and the application terminated.

Could you please give me any information about this breaking change?

Nov 19, 2014 at 12:35 AM
Davide, I just tried this with the MMPPF sample app and confirmed the issue. I was then able to fix the issue by removing and re-adding the Smooth SDK reference to the main project. For some reason, existing projects were missing some of the activatable class entries that VS automatically adds to AppxManifest.xml in the bin directory.

Can you please give this a try?
Nov 19, 2014 at 12:14 PM
Hi Tim,
thanks for your reply.

I've tried to remove and re-add the Smooth SDK reference on the main project of the MMPPF Windows 8.1 sample app but the issue still occurs.

Nov 23, 2014 at 7:16 PM
Hi Tim,

I am also experiencing problems after the install of VS2013 update 4. I got a different error than Davide though. I get the error MEDIA_ERR_SRC_NOT_SUPPORTED and my video does not play anymore.

With VS2013 update 3 everything was working fine. I also tried your suggestion of removing and readding the Smooth SDK reference but that did not help.

Any ideas?

Nov 23, 2014 at 7:39 PM
Here's a workaround while we work on a more permanent solution.

Open your pacakage.appxmanifest file in source view (right click in VS and select View Code)

Add the following xml to the end of the file but just inside the package node...

<Extension Category="windows.activatableClass.inProcessServer">



    <ActivatableClass ActivatableClassId="Microsoft.Media.AdaptiveStreaming.AdaptiveSourceManager" ThreadingModel="both" />

    <ActivatableClass ActivatableClassId="Microsoft.Media.AdaptiveStreaming.DownloaderRequest" ThreadingModel="both" />

    <!--<ActivatableClass ActivatableClassId="Microsoft.Media.AdaptiveStreaming.SmoothSchemeHandler" ThreadingModel="both" />-->

    <!--<ActivatableClass ActivatableClassId="Microsoft.Media.AdaptiveStreaming.HttpCookie" ThreadingModel="both" />-->

    <ActivatableClass ActivatableClassId="Microsoft.Media.AdaptiveStreaming.DownloaderResponse" ThreadingModel="both" />

    <!--<ActivatableClass ActivatableClassId="Microsoft.Media.AdaptiveStreaming.SmoothByteStreamHandler" ThreadingModel="both" />-->

    <!--<ActivatableClass ActivatableClassId="Microsoft.Media.AdaptiveStreaming.AdaptiveSource" ThreadingModel="both" />-->


Nov 23, 2014 at 8:09 PM
Thank you, Tim.

The workaround solves the issue.
Nov 24, 2014 at 7:22 AM

This also solves the problem for me.

Thanks for the quick reply!